HackDig : Dig high-quality web security articles for hacker

Magento Users Warned of Remote Code Execution Vulnerability

2019-11-12 22:15

Popular ecommerce platform Magento is advising users to apply patches for a remote code execution flaw that could allow unauthenticated attackers to deliver malicious payloads.

Tracked as CVE-2019-8144 and featuring a CVSS score of 10, the vulnerability impacts Magento 2.3 prior to 2.3.3 or 2.3.2-p1 and it can be abused to insert code through PageBuilder template methods.

A security update Magento released on October 8 addresses this issue, along with various other security flaws, but many installations remain vulnerable because users haven’t applied the available patches yet.

“This vulnerability could enable an unauthenticated user to insert a malicious payload into a merchant’s site and execute it, which is why we recommend installing this update,” the ecommerce platform notes in a new blog post.

Magento Commerce 2.3.3 and the security-only patch 2.3.2-p2 address the vulnerability.

Magento Commerce 2.3.1, Magento Commerce 2.3.2 deployments that have not had the security-only patch 2.3.2-p2 installed, and unsupported versions of Page Builder, such as Page Builder Beta, remain vulnerable to attacks.

“We recommend that all merchants, even those who have already upgraded to 2.3.3 or applied security-only patch 2.3.2-p2, review the security of their Magento site to confirm that it was not potentially compromised before upgrade,” Magento now says.

In addition to applying the available patches (MDVA-22979_EE_2.3.1_v1 for Magento 2.3.1 and MDVA-22979_EE_2.3.2_v1 for Magento 2.3.2), merchants are advised to plan an upgrade to 2.3.3 or 2.3.2-p2 as soon as possible.

At the same time, Magento recommends checking websites and servers for any signs of potential compromise.

Magento also explains that, in order to protect customers, it has implemented measures that help block the exploitation of this vulnerability, but that this resulted in blocking administrators from viewing previews for products, blocks, and dynamic blocks.

“We will re-enable the preview functionality as soon as possible,” Magento says.

Magento-based ecommerce websites have been targeted by various cybercrime groups, with some of the most recent attacks against them attributed to the Magecart hackers.

Such attacks could be highly damaging to both merchants and users, as they result in the exfiltration of credit card data and the theft of funds from compromised accounts.

Related: Magecart Hackers Now Targeting Vulnerable Magento Extensions

Related: Hacked Magento Sites Steal Card Data, Spread Malware

Related: Magento Patches Critical Vulnerabilities


Source: oitucexe-edoc-etomer-denraw-sresu-otnegam/ouQxTDN_uTa/3~/keewytiruceS/r~/moc.elgoog.yxorpdeef

Read:294 | Comments:0 | Tags:NEWS & INDUSTRY Virus & Threats Vulnerabilities Vuln

“Magento Users Warned of Remote Code Execution Vulnerability”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Announce

Share high-quality web security related articles with you:)

Tools

Tag Cloud