HackDig : Dig high-quality web security articles for hacker

OpenSSL patches vulnerabilities discovered with Google OSS-Fuzz fuzzing service

2017-11-03 08:40

OpenSSL patches two low and medium severity vulnerabilities that were discovered by using Google’s open source OSS-Fuzz fuzzing service.

The medium severity vulnerability tracked as CVE-2017-3736 was addressed with the release of OpenSSL 1.1.0g and 1.0.2m.

The flaw is a carry propagating bug in the x86_64 Montgomery squaring procedure, it affects processors that support BMI1, BMI2 and ADX extensions, such as Intel Broadwell 5th generation and later and the AMD Ryzen.

An attacker can exploit this kind of vulnerability to recover encryption keys and access protected communications.

“There is a carry propagating bug in the x86_64 Montgomery squaring procedure. No
EC algorithms are affected.” read the OpenSSL advisory.

“Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH are considered just feasible (although very difficult) because most of the work necessary to deduce information about a private key may be performed offline,” 

The OpenSSL development team believe that trigger the issue in a real scenario attack is difficult due to the significant effort needed.

“The amount of resources required for such an attack would be very significant and likely only accessible to a limited number of attackers. An attacker would additionally need online access to an unpatched system using the target private key in a scenario with persistent DH parameters and a private key that is shared between multiple clients,” continues the advisory.

The CVE-2017-3736 vulnerability is very similar to CVE-2015-3193 that was patched in December 2015, and CVE-2017-3732 fixed in January, however, OpenSSL developers highlight it needs to be treated separately.

The second flaw, tracked as CVE-2017-3735, was patched with the release of OpenSSL 1.1.0g and 1.0.2m, it is a low severity issue that could lead to an out-of-bounds (OOB) read.

The vulnerability disclosed in August 2016 has existed since 2006, the source code patch was available since August.

“If an X.509 certificate has a malformed IPAddressFamily extension, OpenSSL could do a one-byte buffer overread. The most likely result would be an erroneous display of the certificate in text format. As this is a low severity fix, no release is being made. The fix can be found in the source repository (1.0.2, 1.1.0, and master branches); see
https://github.com/openssl/openssl/pull/4276. This bug has been present
since 2006.” reads the advisory.

“This issue was found by Google’s OSS-Fuzz project on August 22. The fix was developed by Rich Salz of the OpenSSL development team.”

Both vulnerabilities were discovered using OSS-Fuzz, an open source fuzzing service launched by Google in December.

“OSS-Fuzz’s goal is to make common software infrastructure more secure and stable by combining modern fuzzing techniques with scalable distributed execution. OSS-Fuzz combines various fuzzing engines (initially, libFuzzer) with Sanitizers (initially, AddressSanitizer) and provides a massive distributed execution environment powered by ClusterFuzz.” wrote Google when announced the service.

Five months after the launch of OSS-Fuzz, Google revealed that its robot army has been working hard at fuzzing, processing 10 trillion test inputs a day.

The fuzzer helped find 264 potential security vulnerabilities in 47 open source projects.

oss-fuzz results

Pierluigi Paganini

(Security Affairs – oss-fuzz, OpenSSL)

The post OpenSSL patches vulnerabilities discovered with Google OSS-Fuzz fuzzing service appeared first on Security Affairs.


Source: lmth.gnizzuf-zzuf-sso-elgoog-lssnepo/ytiruces/79056/sserpdrow/oc.sriaffaytiruces

Read:1972 | Comments:0 | Tags:Breaking News Hacking Security Google OpenSSL. encryption os

“OpenSSL patches vulnerabilities discovered with Google OSS-Fuzz fuzzing service”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Announce

Share high-quality web security related articles with you:)

Tools

Tag Cloud