HackDig : Dig high-quality web security articles

Popular Django web framework affected by a SQL Injection flaw. Upgrade it now!

2022-07-04 11:10

The development team behind the Django Project has addressed a high-severity SQL Injection flaw in its framework.

Django is a free and open-source, Python-based web framework that follows the model–template–views (MTV) architectural pattern. Django is maintained by the independent organization Django Software Foundation.

django

The latest releases of the framework, Django 4.0.6 and 3.2.14, addressed a high-severity SQL Injection vulnerability tracked as CVE-2022-34265.

According to the release note, the flaw resides in the Trunc() and Extract() database functions, it can be exploited if untrusted data was used as a kind/lookup_name value. Performing input sanitization for these functions it is possible to mitigate the risk of exploitation of the flaw.

“Trunc() and Extract() database functions were subject to SQL injection if untrusted data was used as a kind/lookup_name value.” reads the note. “Applications that constrain the lookup name and kind choice to a known safe list are unaffected.”

The development team also releases security patches as temporary solutions before upgrading to the latest versions.

Follow me on Twitter: @securityaffairs and Facebook

Pierluigi Paganini

(SecurityAffairs – hacking, SQL Injection)

The post Popular Django web framework affected by a SQL Injection flaw. Upgrade it now! appeared first on Security Affairs.


Source: lmth.noitcejni-lqs-krowemarf-ognajd/ytiruces/358231/sserpdrow/oc.sriaffaytiruces

“Popular Django web framework affected by a SQL Injection flaw. Upgrade it now!”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Announce

Share high-quality web security related articles with you:)
Tell me why you support me <3

Tag Cloud