HackDig : Dig high-quality web security articles

CISA Says 'PwnKit' Linux Vulnerability Exploited in Attacks

2022-06-28 16:12

The US Cybersecurity and Infrastructure Security Agency (CISA) says a Linux vulnerability tracked as CVE-2021-4034 and PwnKit has been exploited in attacks.

The flaw, which came to light in January, affects Polkit, a component designed for controlling system-wide privileges in Unix-like operating systems. Polkit is developed by Red Hat, but it’s also used by other Linux distributions.

PwnKit has been described as a memory corruption issue that can be exploited for privilege escalation — it allows any unprivileged local user to elevate permissions to root.

The vulnerability has been found to impact the products of several major companies. Juniper Networks, Moxa, IBM, VMware, Siemens and others have released advisories to describe the impact of CVE-2021-4034.

Proof-of-concept (PoC) exploits have been available and exploitation is easy, which is why experts have been warning that the likelihood of malicious exploitation is high.

CISA on Monday added the vulnerability to its Known Exploited Vulnerabilities Catalog — also known as the agency’s “Must Patch” list — and instructed federal agencies to install patches until July 18.

While there do not appear to be any public reports describing attacks that involve exploitation of PwnKit, CISA only adds a vulnerability to its Must Patch list if it has reliable evidence of exploitation in the wild. It’s possible that the agency has privately obtained the information about active exploitation.

Security experts noted that while exploitation of CVE-2021-4034 should leave traces in log files, it’s also possible to exploit the flaw without leaving such traces.

In addition to the PwnKit vulnerability, CISA has added seven other flaws to its catalog, including a recent Mitel VOIP zero-day exploited in ransomware attacks, a Chromium vulnerability exploited in malvertising campaigns, and several iOS vulnerabilities that have been exploited by Italian spyware.

Federal agencies have been instructed to address all of these vulnerabilities by July 18, but private companies are also advised to use CISA’s catalog to prioritize patches and improve their vulnerability management processes.

Related: CISA Clarifies Criteria for Adding Vulnerabilities to 'Must Patch' List

Related: CISA Says 'HiveNightmare' Windows Vulnerability Exploited in Attacks

Related: CISA Warns of Attacks Exploiting Recent Vulnerabilities in Zabbix Monitoring Tool

Related: CISA Says Recent Cisco Router Vulnerabilities Exploited in Attacks


Source: skcatta-detiolpxe-ytilibarenluv-xunil-tiknwp-syas-asic/moc.keewytiruces.www

Read:379 | Comments:0 | Tags:NEWS & INDUSTRY Virus & Threats Vulnerabilities Vuln

“CISA Says 'PwnKit' Linux Vulnerability Exploited in Attacks”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Announce

Share high-quality web security related articles with you:)
Tell me why you support me <3

Tag Cloud