HackDig : Dig high-quality web security articles for hackers

VMware Patches Several Vulnerabilities Allowing Code Execution on Hypervisor

2020-06-24 13:51

VMware informed customers on Tuesday that it addressed a total of 10 vulnerabilities affecting its ESXi, Workstation and Fusion products, including critical and high-severity flaws that can be exploited for code execution on the hypervisor.

The most serious of the vulnerabilities is CVE-2020-3962, a critical use-after-free bug related to the SVGA device. An attacker who has local access to a virtual machine (VM) with 3D graphics enabled can exploit the weakness for arbitrary code execution on the hypervisor from the VM.

VMware has pointed out that 3D graphics are enabled by default on Workstation and Fusion, but not on ESXi.

A very similar vulnerability patched this week by the virtualization giant is an off-by-one heap overflow bug related to the SVGA device. Exploitation of this vulnerability requires the same types of permissions and it can also result in code execution, but it has been rated high severity instead of critical due to the attack complexity being assigned as high — the attack complexity is considered low for the previous flaw.

“Additional conditions beyond the attacker's control must be present for exploitation to be possible,” VMware said in its advisory.

Another high-severity vulnerability affecting ESXi, Workstation and Fusion has been described as a heap overflow affecting the USB 2.0 controller. Similar to the aforementioned security holes, this one also allows an attacker with local access to a VM to execute arbitrary code on the hypervisor.

The same USB 2.0 controller is impacted by a race condition that causes a heap overflow. This bug can also allow arbitrary code execution on the hypervisor, but exploitation is only possible against certain configurations.

A high-severity vulnerability identified in the USB 3.0 controller allows an attacker with admin privileges on the VM to cause a denial-of-service (DoS) condition or execute arbitrary code on the hypervisor. Another high-severity issue affecting this controller can be leveraged by a local attacker to read privileged information from memory.

Other flaws patched by the company have been rated medium severity and they can be exploited by local attackers to cause a DoS condition or to read privileged information from memory.

Many of the vulnerabilities were reported to VMware by various researchers through Trend Micro’s Zero Day Initiative, and several were identified by a researcher from Google. The same Google employee was credited recently by VMware for a high-severity information disclosure flaw affecting Workstation, Fusion and vSphere.

Related: Details Released for Flaw Allowing Full Control Over VMware Deployments

Related: Hackers Can Compromise VMware vCenter Server Via Newly Patched Flaw

Related: Remote Code Execution Vulnerability Patched in VMware Cloud Director


Source: la-seitilibarenluv-lareves-sehctap-erawmv/svKuu2hqef3/3~/keewytiruceS/r~/moc.elgoog.yxorpdeef

Read:165 | Comments:0 | Tags:NEWS & INDUSTRY Vulnerabilities

“VMware Patches Several Vulnerabilities Allowing Code Execution on Hypervisor”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Announce

Share high-quality web security related articles with you:)

Tools