HackDig : Dig high-quality web security articles for hacker

Remotely Exploitable flaws affect SAP solutions

2015-05-15 07:10

SAP products make use of a proprietary implementation of LZC and LZH compression algorithms that could be exploited by attackers in several ways.

For the second time in a week, we are speaking about security vulnerabilities affecting SAP systems, recently I wrote about a study published by the Onapsis firm that revealed over 95% of SAP systems are exposed to vulnerabilities that could lead to full compromise of the company’s business.

This time a proprietary implementation of a popular protocol has created a flaw that could be exploited by hackers, the vulnerability affects SAP data compression software and open to remote code execution and denial-of-service attacks.

SAP systems

The researcher Martin Gallo of Core Security Consulting Services has discovered several vulnerabilities in the decompression routines of two compression algorithms, Lempel-Ziv-Thomas (LZC) adaptive dictionary compression algorithm and the Lempel-Ziv-Huffman (LZH) compression algorithm, implemented by SAP in its solutions.

“SAP products make use of a proprietary implementation of the Lempel-Ziv-Thomas (LZC) adaptive dictionary compression algorithm and the Lempel-Ziv-Huffman (LZH) compression algorithm [1] . These compression algorithms are used across several SAP products and programs. Vulnerabilities were found in the decompression routines that could be triggered in different scenarios, and could lead to execution of arbitrary code and denial of service conditions.” states the vulnerability description provided by the experts.

The researchers demonstrated that he is able to remotely and locally exploit the flaw.  Gallo ethically disclosed his findings with SAP that has fixed these vulnerabilities, now administrators urge to update their systems to patch the bugs.

The two vulnerabilities, coded as CVE-2015-2282 and CVE-2015-2278, is a pair of out-of-bounds reads and writes as reported at Full Disclosure Mailing List.

As reported in the advisory published by Coresecurity, the affected packages are:

  • SAP Netweaver Application Server ABAP.
  • SAP Netweaver Application Server Java.
  • SAP Netweaver RFC SDK.
  • SAP RFC SDK.
  • SAP GUI.
  • SAP MaxDB database.
  • SAPCAR archive tool.

The experts highlighted the possibility to run a server-side attack, a client-side attack and Man-in-the-middle attacks.

The server-side components can be attacked by sending crafted packets from a malicious client, the attackers will send a crafted .SAR or .CAR archive to a client to exploit the vulnerability. .SAR or .CAR archive to a client to exploit the vulnerability. .SAR or .CAR archive to a client to exploit the vulnerability. .SAR or .CAR archive to a client to exploit the vulnerability..SAR or .CAR archive to a client to exploit the vulnerability.

Due to the lack of encryption by default, the attackers might be able to run a man-in-the-middle attack and trigger the vulnerabilities by injecting malicious packets within the communication.

SAP issued the following security notes to address the vulnerabilities

  • 2124806
  • 2121661
  • 2127995
  • 2125316

Pierluigi Paganini

(Security Affairs – SAP, Hacking)

The post Remotely Exploitable flaws affect SAP solutions appeared first on Security Affairs.


Source: th.snoitulos-pas-tceffa-swalf-elbatiolpxe-yletomer/gnikcah/61863/sserpdrow/oc.sriaffaytiruces

Read:1924 | Comments:0 | Tags:Breaking News Hacking Security CVE-2015-2278 CVE-2015-2282 D

“Remotely Exploitable flaws affect SAP solutions”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Announce

Share high-quality web security related articles with you:)

Tools

Tag Cloud