HackDig : Dig high-quality web security articles for hacker

Security updates fix critical vulnerabilities in Flash player and Shockwave player

2017-03-15 06:55

Adobe patches vulnerabilities in Flash Player and Shockwave for Windows, Mac, Linux and Chrome OS.

Adobe issued security updates for Flash Player and Shockwave Player products. The security updates released by the company on Tuesday address seven vulnerabilities in Flash Player and one flaw in Shockwave Player.

The Flash Player 25.0.0.127 version fixes critical security vulnerabilities that affect version 24.0.0.221 and earlier on Windows, Mac, Linux and Chrome OS.

 

The flaws could be exploited by an attacker to gain control over the vulnerable system.

“Adobe has released security updates for Adobe Flash Player for Windows, Macintosh, Linux and Chrome OS. These updates address critical vulnerabilities that could potentially allow an attacker to take control of the affected system. ” reads the security advisory published by Adobe.

The list of vulnerabilities addressed by the security updates includes a buffer overflow CVE-2017-2997 flaw, two memory corruption issues (CVE-2017-2998, CVE-2017-2999), a random number generator flaw (CVE-2017-3000), and three use-after-free vulnerabilities (CVE-2017-3001, CVE-2017-3002, CVE-2017-3003).

Adobe thanked the following researchers for reporting the flaws:

  • Tao Yan (@Ga1ois) of Palo Alto Networks (CVE-2017-2997, CVE-2017-2998, CVE-2017-2999)
  • Wang Chenyu and Wu Hongjun of Nanyang Technological University (CVE-2017-3000)
  • Yuki Chen of Qihoo 360 Vulcan Team working with Chromium Vulnerability Rewards Program and Anonymous working with Trend Micro’s Zero Day Initiative (CVE-2017-3001)
  • Yuki Chen of Qihoo 360 Vulcan Team working with Chromium Vulnerability Rewards Program (CVE-2017-3002, CVE-2017-3003)

 Flash Player Shockwave updates

The security updates also fixed an important privilege escalation flaw in Shockwave Player (CVE-2017-2983) related to the directory search path used to find resources.

The flaw discovered by Nitesh Shilpkar.

According to Adobe, there is no evidence that vulnerabilities fixed by the security updates have been exploited by threat actors in the wild.

Pierluigi Paganini

(Security Affairs – Flash Player, security updates)

The post Security updates fix critical vulnerabilities in Flash player and Shockwave player appeared first on Security Affairs.


Source: lmth.setadpu-evawkcohs-reyalp-hsalf/swen-gnikaerb/44175/sserpdrow/oc.sriaffaytiruces

Read:2183 | Comments:0 | Tags:Breaking News Security Adobe buffer overflow Flash Player pr

“Security updates fix critical vulnerabilities in Flash player and Shockwave player”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Announce

Share high-quality web security related articles with you:)

Tools

Tag Cloud