HackDig : Dig high-quality web security articles for hackers

Patches Released for WordPress Plugin Vulnerabilities Exploited in Attacks

2020-03-03 09:59

Patches released over the past several days for multiple WordPress plugins address vulnerabilities that have been actively exploited as part of the same website takeover campaign

The first of the updated plugins is Flexible Checkout Fields For WooCommerce, a popular application installed on over 20,000 sites. The plugin is impacted by a vulnerability described as an “unauthenticated stored XSS via plugin settings change.”

Considered critical severity and featuring a CVSS score of 9.3, the vulnerability can be exploited by an unauthenticated attacker to modify the plugin’s options, and then inject XSS payloads meant to be triggered in the dashboard of a logged-in administrator.

The security flaw impacts versions 2.3.1 and prior of the plugin and was addressed with the release of version 2.3.2. Additional updates have been released to implement more security measures and site admins are advised to update to the latest version as soon as possible.

While investigating attacks targeting this bug, WordPress security firm Defiant discovered a similar vulnerability in 10Web Map Builder for Google Maps, another plugin with more than 20,000 installations. The issue resides in the plugin’s setup process.

“If an attacker injects malicious JavaScript into certain settings values, the code will execute for administrators in their dashboard as well as front-of-site visitors in some circumstances,” Defiant explains.

Version 1.0.64 of the plugin was released on Friday to address this critical vulnerability.

Adversaries were also observed targeting the Modern Events Calendar Lite plugin, which has over 40,000 installs. The plugin is affected by multiple stored XSS vulnerabilities tracked as CVE-2020-9459 and rated high risk.

Some of the AJAX actions that the plugin registers for logged-in users may allow low-privileged users, such as subscribers, to manipulate settings and other stored data, which could lead to the injection of various XSS payloads.

Depending on where the code was injected, the scripts can be executed in the dashboard, impacting administrators, or on the front of the site, thus affecting visitors. However, Defiant only observed attacks targeting administrators, to create rogue accounts for the attackers.

Version 5.1.7 of Modern Events Calendar Lite was released on Saturday to address the vulnerability.

The campaign was also observed targeting a vulnerability in Async JavaScript, a plugin currently installed on more than 100,000 WordPress sites. Described as a stored XSS related to settings changes, the vulnerability is considered high severity, with a CVSS score of 7.6.

The AJAX action that handles Async JavaScript’s settings is registered only for authenticated users, but there are no capability checks made, which allows low-privilege users to modify the plugin’s settings. This could lead to payloads being injected in such a manner that they are executed when the administrator views certain areas of their dashboard.

The issue was addressed with the release of version 2.20.02.27 of Async JavaScript.

Related: 20,000 WordPress Websites Infected via Trojanized Themes

Related: WordPress Websites Hacked via Vulnerabilities in Two Themes Plugins


Source: arenluv-nigulp-sserpdrow-desaeler-sehctap/sRecuVAfsjE/3~/keewytiruceS/r~/moc.elgoog.yxorpdeef

Read:545 | Comments:0 | Tags:NEWS & INDUSTRY Virus & Threats Vulnerabilities Cybe

“Patches Released for WordPress Plugin Vulnerabilities Exploited in Attacks”0 Comments

Submit A Comment

Name:

Email:

Blog :

Verification Code:

Tools

Tag Cloud